HOME フォーラム BizVektor ある特定のページだけ、CSSが書き出されます

タグ: ,

このトピックには9件の返信が含まれ、5人の参加者がいます。3 週間、 6 日前 zoket さんが最後の更新を行いました。

10件の投稿を表示中 - 1 - 10件目 (全10件中)
  • 投稿者
    投稿
  • #7466

    richriver
    参加者

    いつもお世話になっております。

    あのある時から、Bizvektorの拡張プラグインの種類に限らず、次のCSSが書き出されます。
    全ページではなく一部のページのみ。理由はなんでしょうか?
    ちなみに、次のCSSで検索すると、Bizvektorのテーマで作られたと思われるサイトが多く検索されるので、WordPressの問題というよりBizvektorの問題な気もするのですが、ご教示いただければ助かります。

    .keyColorBG,.keyColorBGh:hover,.keyColor_bg,.keyColor_bg_hover:hover{background-color: #e90000;}.keyColorCl,.keyColorClh:hover,.keyColor_txt,.keyColor_txt_hover:hover{color: #e90000;}.keyColorBd,.keyColorBdh:hover,.keyColor_border,.keyColor_border_hover:hover{border-color: #e90000;}.color_keyBG,.color_keyBGh:hover,.color_key_bg,.color_key_bg_hover:hover{background-color: #e90000;}.color_keyCl,.color_keyClh:hover,.color_key_txt,.color_key_txt_hover:hover{color: #e90000;}.color_keyBd,.color_keyBdh:hover,.color_key_border,.color_key_border_hover:hover{border-color: #e90000;}

    #7468

    magonote
    モデレーター

    >Bizvektorのテーマで作られたと思われるサイトが多く検索される
    見てみましたが、どれも同じで
    ・スキンは関係ない
    ・固定ページでも投稿ページでも発症
    ・投稿ページでも症状があるものとないものがある
    って感じですね。
    共通してるのは</head>の位置がおかしいです。。。本来、head内にあるべきものが、<body>内になだれ込んでますw
    bizvektorのバージョンが原因でもなさそう。
    なんでしょね???(・・?

    画像にキャプションが付いてるパターンが多いですね
    でも全部じゃないし。。。ヒットするのは実質50件弱ぐらいなので、メディア系のプラグインとかが干渉してるんですかねぇ??

    • この返信は1 年、 9 ヶ月前に  magonote さんが編集しました。
    • この返信は1 年、 9 ヶ月前に  magonote さんが編集しました。
    #7474

    richriver
    参加者

    ご返信ありがとうございます。

    >画像にキャプションが付いてるパターンが多い

    そうですね、確かに。
    あの私が更新してるページにもキャプションが付いていましたので、試しにキャプションなしの画像にすると、上記のCSSは消えました。

    写真のキャプションが影響しているのは、間違いなさそうです。
    でもどうしてなんでしょうか、、、

    #7477

    magonote
    モデレーター

    キャプションだけじゃなく、WP付属のショートコードで起こるのかもしれませんねー

    >試しにキャプションなしの画像にすると、上記のCSSは消えました
    私のテストサイトでは、キャプション付けても、何も起こらないんですよね~
    「キャプション+何か」で起こってるのかも?です。

    #7497
    じょに次郎
    じょに次郎
    モデレーター

    んー、Grid Unit かな?

    #7501

    richriver
    参加者

    ご返信ありがとうございます。
    未だ解決には至っておりませんが、私のサイトでは「Grid Unit」は使っておりませんので、ご報告いたします。
    急いではおりませんので、私も時間がある時に、プラグインを一つずつ無効にして、症状が改善するか試してみますね。またその進捗をご報告いたします。

    いま、ちなみにBizVektor系で使っているのは、
    「BizVektor Cuddly」のテーマで、「BizVektor FooterPowerdDelete」と「BizVektor Theme Updater」のみ。
    テーマはBizVektorバージョン: 1.9.12です。

    #10751

    71zu12
    参加者

    はじめまして。
    当方、HTML、CSSはずぶの素人のため、とんちんかんな投稿をしておりましたら申し訳ありません。

    本件、皆様は解決されたのでしょうか?
    昨日、私が携わるサイトでも同じ現象が発生しました。
    下記のことがわかりました。

    1.本件の事象は、本文に記載された下記のソースが影響していました。
    ↓↓↓↓↓↓ここから↓↓↓↓↓↓
    <div class=”ns-box” style=”border-style: solid; border-color: #aaaaaa; background-color: #fafafa;”>
    <p style=”text-align: center;”>●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●
    ●●●●●●●●●●●●●●●●●●●●●●●●
    ●●●●●●●●●●●●●●●●●●●●●●●●●●●●
    ●●●●●●●●●●●●●●●●●●●●●●
    ●●●●●●●●●●●
    ●●●●●●●●●●●●●●●”http://www.●●●●●●●●●●●.com/●●●●●●/●●●●●●●●●●●●●●●●●” target=”blank” size=”6″ wide=”no” center=”yes” icon=”icon: external-link”]●●●●●●●●●●ホームページへ[/su_button]

    </div>
    ↑↑↑↑↑↑ここまで↑↑↑↑↑↑

    2.試行錯誤したところ、下記の変更を加えることで表示が消えました。
    (1)1文字(1バイト、2バイトどちらでも)もしくはスペースを加える
    (2)<p style=”text-align: center;”>で改行する

    とりあえず、当方のサイトでの対処方法はわかったのですが、恒久的な対処ができれば幸です。

    テーマはBizVektorバージョン: Version 1.9.12です。

    #10755

    zoket
    参加者

    はじめまして。私も同様の症状を経験いたしました。
    WordPress 4.9.8 
    子テーマを使用しておりますが、BizVektorバージョン: 1.11.1
    他、PHPバージョン 7.2.10 (CGI版) 、 MySQL 5.7 です。
    Grid Unitは使用しておりません。画像にキャプションもつけておりません。

    症状は、構造の同様な投稿ページが多くある中、特定の投稿ページのみで
    [su_button url=””http://xxxxxxxx.com/”” target=””blank”” background=””#c7d3bc”” color=””#1e4403″” size=””5″” wide=””yes”” icon=””icon: external-link”” icon_color=””#1e4403″”]http://xxxxxxxx.com[/su_button]
    で、リンクurlの最後のスラッシュを省略すると、なぜか</head>後にcssの一部っぽいものが連続5行くらい出力されました。

    リンクを紹介したページは多くありましたが、2件のみ症状が出ました。
    どちらも.comで終わるurlでしたが、他にも.comのurlを含む記事があり、そちらは大丈夫だったのです。

    やはりショートコードの [ ] と、何かの組み合わせで発症するのではと思いましたが、原因は判明せず、ご報告のみとなります。。。

    #10756
    じょに次郎
    じょに次郎
    モデレーター

    あー、多分本文中のショートコードが description に吐き出されておかしくなってるのかもしれないですね。
    簡易的な回避としては抜粋欄に日本語で普通に入力すれば解消されませんかね?

    #10757

    zoket
    参加者

    じょに次郎様

    回避策ありがとうございます。当方の該当投稿にて確認したところ、解決されました。
    また、確かに description 内に吐き出されたショートコードが原因と思われるものでした。

    <meta name="description" content="●●●●●●●●●●●" />
    の●●●●●●●●●●●部分にショートコードがそのまま入っており、かつ、
    ●●●●●●●●●●●の末尾が   =   となっていた場合に症状があらわれました。

    descriptionの直後にある、=や”を使用する行に影響が出るようでした。

    ショートコード内の項目を入れ替えたり、項目間の半角スペースをひとつ増やすなどして
    末尾に  =  が来ないようにして解決することもできました。

    以上ご報告となります。
    – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

    (上記書き込み #10755 内の”の数がおかしなことになっていてすみません)

10件の投稿を表示中 - 1 - 10件目 (全10件中)

このトピックに返信するにはログインが必要です。